Win7 + 安装 .NET 4.8 教程 和 安装失败原因分析

Qiss 2018-12-23 3944


D3DCompiler  补丁包


Win 7 SP1 X86 Win7 SP1 / Server 2008 R2 x64  Server 2012 x64 


 .net framwork 4.8 框架


 离线安装 在线安装   (在线安装会自动装补丁包)


 .net framwork 4.8 语言


简体中文语言 【其他语言包,请从微软官网下载


===================================================================

安装教程

===================================================================


本教程的截图和相关步骤使用的电脑系统是 win 7 SP1,框架是 Net 4.7.2


第一步:


根据自身的电脑系统选择D3DCompiler  补丁包,这里显示的是对系统版本最低要求。


1.如果你的系统是Win7 32 位,应该下载 Win 7 SP1 X86


2.如果你的系统是Win7 64 位,应该下载 Win7 SP1 / Server 2008 R2 x64


3.如果你是安装到服务器,务必保证服务器系统为64位,WinServer 2008以上.


a.如果的你服务器是Server 2008,应该下载 Win7 SP1 / Server 2008 R2 x64


b.如果的你服务器是Server 2012,应该下载 Server 2012 x64 


第二步:


安装.NET框架,复制离线安装的地址到迅雷,因为有缓存,所以,可以高速下载


1.离线安装,一个完整的安装包文件,运行后,释放文件就安装,无需联网。【推荐】

2.在线安装,一个很小的WEB的程序,运行后,边下载边安装,如果网络不稳定,会安装失败。


第三步:


安装中文语言包,替换默认的英文提示为中文提示。


安装成功后的 .NET 框架,如果运行某些软件出错了,默认提示是英文的。对普通用户不太用好。

那么,就可以安装中文语言包本地化,那么报错时,显示的提示,按钮文字都将变成对应的中文。


===================================================================

失败原因

===================================================================


Win7 是可以安装 .net framwork 4.8 ,不能安装是因为没有安装补丁。


如果无法安装补丁,或者安装补丁后依旧失败,那么是阉割版系统的原因,只能尝试重装系统。


出现:已处理证书链,但是在不受信任提供程序信任的根证书中终止 。或者提示不受支持,类似这样的错误。



那么应该先安装补丁,其实为避免安装到最后失败,可以直接先装补丁,如果已经有补丁则会取消安装补丁。



安装补丁,需要根据自己的系统,进行下载对应的补丁。不要下载错误版本的补丁。


==========================================================

还有一种情况,就是用户电脑系统很旧,没有装上SP1补丁,那么需要先给系统安装必备的补丁

根据你的系统选择对应的补丁进行下载,64位系统选择  windows6.1-KB976932-X64.exe

根据你的系统选择对应的补丁进行下载,32位系统选择  windows6.1-KB976932-X86.exe

下载完成后,进行补丁安装,安装完成后,重新安装 .Net 框架

===========================================================

如果你的需要其他类型的SP1补丁,可以按照下面的链接进入下载.....

下载其他SP1补丁:Windows 7 和 Windows Server 2008 R2 Service Pack 1 (KB976932)



最新回复 (0)
返回
发新帖